Discussion:
daemon manager not running
Jody Reed
2013-04-25 18:59:19 UTC
Permalink
I'm still trying to figure out the ins and outs of Plone. I am using 4.2.4 and installed using unified installer.

Today Ubuntu did some updates (running 12.1) Stupid me I did not pay close attention to what. And now my Plone is troubled.

I have been banging away at it for a couple hours, and hope I haven't buggered it completely. Good thing it's just a test site, bad is I'm supposed to present on it next week...

Basically after the Ubuntu updates I lost my connection to blob storage or that is what it seemed.

Unfortunately i didn't copy the trace at the time. I went back and tried restoring the blobstorage and data.fs that I had backed up via repozo backup script.

Problem is now the site won't load at all.

running 'bin/plonectl start' nets:





zeoserver: . Error: The directory named as part of the path /usr/local/Plone/zeocluster/var/zeoserver/zeoserver.pid does not exist.

(line 10 in file:///usr/local/Plone/zeocluster/parts/zeoserver/etc/zeo.conf)

For help, use /usr/local/Plone/zeocluster/bin/zeoserver -h

. . . . . . . . . .

daemon manager not running

client1: .

daemon process started, pid=27564

client2:

daemon process started, pid=27566



I have rebooted, rebuilt buildout, stopped and restarted Plone but still nothing is working...



I'm getting lost here, and before I totally screw things up (if i haven't already) I would like some feedback.







Jody Reed
Information Systems Assistant

<http://www.lmgfinance.ca>

Email jreed-ZWCkQTszN2++***@public.gmane.org <mailto:jreed-ZWCkQTszN2++***@public.gmane.org?subject=Reply%20to%20email%20signature> | www.lmgfinance.ca <http://www.lmgfinance.ca/>

Toll Free 877.806.6247 | Fax 877.806.6249 | Local 250.374.8804

347 Victoria Street, Suite 201, Kamloops, BC, V2C 2A3

Canada's F&I Outsource Solution

________________________________

This e-mail may be privileged and/or confidential, and the sender does not waive any related rights and obligations. Any distribution, use or copying of this e-mail or the information it contains by other than an intended recipient is unauthorized. If you received this e-mail in error, please advise me (by return e-mail or otherwise) immediately.

Ce courrier électronique est confidentiel et protégé. L'expéditeur ne renonce pas aux droits et obligations qui s'y rapportent. Toute diffusion, utilisation ou copie de ce message ou des renseignements qu'il contient par une personne autre que le (les) destinataire(s) désigné(s) est interdite. Si vous recevez ce courrier électronique par erreur, veuillez m'en aviser immédiatement, par retour de courrier électronique ou par un autre moyen.
Nathan Van Gheem
2013-04-25 19:23:49 UTC
Permalink
That's odd, system updates should not affect a plone install done with the
unified installer usually.

Normally when I see the error you're seeing it's because the user running
the plone process no longer has access to the var directory.

Why don't you try something like:

sudo chown -R plone /usr/local/Plone/zeocluster/var/
** ** ** ** ** ** ** **
I'm still trying to figure out the ins and outs of Plone. I am using 4.2.4
and installed using unified installer.****
Today Ubuntu did some updates (running 12.1) Stupid me I did not pay close
attention to what. And now my Plone is troubled.****
I have been banging away at it for a couple hours, and hope I haven't
buggered it completely. Good thing it’s just a test site, bad is I'm
supposed to present on it next week...****
Basically after the Ubuntu updates I lost my connection to blob storage or
that is what it seemed.****
Unfortunately i didn't copy the trace at the time. I went back and tried
restoring the blobstorage and data.fs that I had backed up via repozo
backup script.****
Problem is now the site won't load at all.****
running 'bin/plonectl start' nets:****
** **
** **
zeoserver: . Error: The directory named as part of the path
/usr/local/Plone/zeocluster/var/zeoserver/zeoserver.pid does not exist.***
*
(line 10 in
file:///usr/local/Plone/zeocluster/parts/zeoserver/etc/zeo.conf)****
For help, use /usr/local/Plone/zeocluster/bin/zeoserver -h****
. . . . . . . . . .****
daemon manager not running****
client1: .****
daemon process started, pid=27564****
client2:****
daemon process started, pid=27566****
** **
I have rebooted, rebuilt buildout, stopped and restarted Plone but still
nothing is working…****
** **
I'm getting lost here, and before I totally screw things up (if i haven't
already) I would like some feedback.****
** **
** **
** **
***Jody Reed***
Information Systems Assistant ****
[image: LMG Finance Logo] <http://www.lmgfinance.ca>****
****
Toll Free 877.806.6247 | Fax 877.806.6249 | Local 250.374.8804 ****
****347 Victoria Street, Suite 201**, **Kamloops**, **BC**, **V2C 2A3****
****
****Canada****'s F&I Outsource Solution ****
------------------------------
This e-mail may be privileged and/or confidential, and the sender does not
waive any related rights and obligations. Any distribution, use or copying
of this e-mail or the information it contains by other than an intended
recipient is unauthorized. If you received this e-mail in error, please
advise me (by return e-mail or otherwise) immediately. ****
Ce courrier électronique est confidentiel et protégé. L'expéditeur ne
renonce pas aux droits et obligations qui s'y rapportent. Toute diffusion,
utilisation ou copie de ce message ou des renseignements qu'il contient par
une personne autre que le (les) destinataire(s) désigné(s) est interdite.
Si vous recevez ce courrier électronique par erreur, veuillez m'en aviser
immédiatement, par retour de courrier électronique ou par un autre moyen.
****
** **
------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt! http://p.sf.net/sfu/newrelic_d2d_apr
_______________________________________________
Plone-Users mailing list
https://lists.sourceforge.net/lists/listinfo/plone-users
Jody Reed
2013-04-25 19:46:03 UTC
Permalink
Had changed ownership so I could check backup files, so changed back to plone via sudo chown -R plone var

And got at least splash screen to show, but upon trying to enter my site got this error:



CorruptedDataError() (Also, the following error occurred while

attempting to render the standard error message, please see the event

log for full details: Error reading oid 0x0182. Found '' at 60830636)



stopping and starting netted this result:



***@plone:/usr/local/Plone/zeocluster$ sudo bin/plonectl start

zeoserver: . . . . . . . . . . .

daemon manager not running

client1: daemon process already running; pid=28221

client2: daemon process already running; pid=28230



________________________________

From: Nathan Van Gheem [mailto:vangheem-***@public.gmane.org]
Sent: Thursday, April 25, 2013 12:24 PM
To: Jody Reed
Cc: plone-users
Subject: Re: [Plone-Users] daemon manager not running



That's odd, system updates should not affect a plone install done with the unified installer usually.



Normally when I see the error you're seeing it's because the user running the plone process no longer has access to the var directory.



Why don't you try something like:



sudo chown -R plone /usr/local/Plone/zeocluster/var/



On Thu, Apr 25, 2013 at 1:59 PM, Jody Reed <jreed-ZWCkQTszN2++***@public.gmane.org> wrote:

I'm still trying to figure out the ins and outs of Plone. I am using 4.2.4 and installed using unified installer.

Today Ubuntu did some updates (running 12.1) Stupid me I did not pay close attention to what. And now my Plone is troubled.

I have been banging away at it for a couple hours, and hope I haven't buggered it completely. Good thing it's just a test site, bad is I'm supposed to present on it next week...

Basically after the Ubuntu updates I lost my connection to blob storage or that is what it seemed.

Unfortunately i didn't copy the trace at the time. I went back and tried restoring the blobstorage and data.fs that I had backed up via repozo backup script.

Problem is now the site won't load at all.

running 'bin/plonectl start' nets:





zeoserver: . Error: The directory named as part of the path /usr/local/Plone/zeocluster/var/zeoserver/zeoserver.pid does not exist.

(line 10 in file:///usr/local/Plone/zeocluster/parts/zeoserver/etc/zeo.conf)

For help, use /usr/local/Plone/zeocluster/bin/zeoserver -h

. . . . . . . . . .

daemon manager not running

client1: .

daemon process started, pid=27564

client2:

daemon process started, pid=27566



I have rebooted, rebuilt buildout, stopped and restarted Plone but still nothing is working...



I'm getting lost here, and before I totally screw things up (if i haven't already) I would like some feedback.







Jody Reed
Information Systems Assistant

<http://www.lmgfinance.ca>

Email jreed-ZWCkQTszN2++***@public.gmane.org <mailto:jreed-ZWCkQTszN2++***@public.gmane.org?subject=Reply%20to%20email%20signature> | www.lmgfinance.ca <http://www.lmgfinance.ca/>

Toll Free 877.806.6247 | Fax 877.806.6249 | Local 250.374.8804

347 Victoria Street, Suite 201, Kamloops, BC, V2C 2A3

Canada's F&I Outsource Solution

________________________________

This e-mail may be privileged and/or confidential, and the sender does not waive any related rights and obligations. Any distribution, use or copying of this e-mail or the information it contains by other than an intended recipient is unauthorized. If you received this e-mail in error, please advise me (by return e-mail or otherwise) immediately.

Ce courrier électronique est confidentiel et protégé. L'expéditeur ne renonce pas aux droits et obligations qui s'y rapportent. Toute diffusion, utilisation ou copie de ce message ou des renseignements qu'il contient par une personne autre que le (les) destinataire(s) désigné(s) est interdite. Si vous recevez ce courrier électronique par erreur, veuillez m'en aviser immédiatement, par retour de courrier électronique ou par un autre moyen.
TsungWei Hu
2013-04-25 22:44:25 UTC
Permalink
First, I would try running bin/buildout to rebuild.

Second, I will use a regular Linux account (not root) to run Plone instace
at $HOME directory.

Anyway, good luck!
** ** ** ** ** ** ** **
Had changed ownership so I could check backup files, so changed back to
plone via sudo chown –R plone var****
And got at least splash screen to show, but upon trying to enter my site
got this error:****
** **
CorruptedDataError() (Also, the following error occurred while ****
attempting to render the standard error message, please see the event ****
log for full details: Error reading oid 0x0182. Found '' at 60830636)****
** **
stopping and starting netted this result:****
** **
zeoserver: . . . . . . . . . . .****
daemon manager not running****
client1: daemon process already running; pid=28221****
client2: daemon process already running; pid=28230****
** **
------------------------------
*Sent:* Thursday, April 25, 2013 12:24 PM
*To:* **Jody Reed**
*Cc:* plone-users
*Subject:* Re: [Plone-Users] daemon manager not running****
** **
That's odd, system updates should not affect a plone install done with the
unified installer usually.****
** **
Normally when I see the error you're seeing it's because the user running
the plone process no longer has access to the var directory.****
** **
Why don't you try something like:****
** **
sudo chown -R plone /usr/local/Plone/zeocluster/var/****
** **
wrote:****
I'm still trying to figure out the ins and outs of Plone. I am using 4.2.4
and installed using unified installer.****
Today Ubuntu did some updates (running 12.1) Stupid me I did not pay close
attention to what. And now my Plone is troubled.****
I have been banging away at it for a couple hours, and hope I haven't
buggered it completely. Good thing it’s just a test site, bad is I'm
supposed to present on it next week...****
Basically after the Ubuntu updates I lost my connection to blob storage or
that is what it seemed.****
Unfortunately i didn't copy the trace at the time. I went back and tried
restoring the blobstorage and data.fs that I had backed up via repozo
backup script.****
Problem is now the site won't load at all.****
running 'bin/plonectl start' nets:****
****
****
zeoserver: . Error: The directory named as part of the path
/usr/local/Plone/zeocluster/var/zeoserver/zeoserver.pid does not exist.***
*
(line 10 in
file:///usr/local/Plone/zeocluster/parts/zeoserver/etc/zeo.conf)****
For help, use /usr/local/Plone/zeocluster/bin/zeoserver -h****
. . . . . . . . . .****
daemon manager not running****
client1: .****
daemon process started, pid=27564****
client2:****
daemon process started, pid=27566****
****
I have rebooted, rebuilt buildout, stopped and restarted Plone but still
nothing is working
****
****
I'm getting lost here, and before I totally screw things up (if i haven't
already) I would like some feedback.****
****
****
****
***Jody Reed***
Information Systems Assistant ****
[image: LMG Finance Logo] <http://www.lmgfinance.ca>****
****
Toll Free 877.806.6247 | Fax 877.806.6249 | Local 250.374.8804 ****
****347 Victoria Street, Suite 201**, **Kamloops**, **BC**, **V2C 2A3****
****
****Canada****'s F&I Outsource Solution ****
------------------------------
This e-mail may be privileged and/or confidential, and the sender does not
waive any related rights and obligations. Any distribution, use or copying
of this e-mail or the information it contains by other than an intended
recipient is unauthorized. If you received this e-mail in error, please
advise me (by return e-mail or otherwise) immediately. ****
Ce courrier électronique est confidentiel et protégé. L'expéditeur ne
renonce pas aux droits et obligations qui s'y rapportent. Toute diffusion,
utilisation ou copie de ce message ou des renseignements qu'il contient par
une personne autre que le (les) destinataire(s) désigné(s) est interdite.
Si vous recevez ce courrier électronique par erreur, veuillez m'en aviser
immédiatement, par retour de courrier électronique ou par un autre moyen.
****
****
------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt! http://p.sf.net/sfu/newrelic_d2d_apr
_______________________________________________
Plone-Users mailing list
https://lists.sourceforge.net/lists/listinfo/plone-users****
** **
------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt! http://p.sf.net/sfu/newrelic_d2d_apr
_______________________________________________
Plone-Users mailing list
https://lists.sourceforge.net/lists/listinfo/plone-users
Nathan Van Gheem
2013-04-26 02:54:05 UTC
Permalink
Jody,

As long as you have the blobstorage directory and the Data.fs, you're fine.

Do not bother re-installing the OS.

The "ClientDisconnected" error means that the zeoserver isn't run OR the
client lost connection to the zeoserver. Try restarting zeoserver and/os
client and it should fix it.

Additionally, it's useful to attempt starting the zeoserver and clients in
foreground mode when debugging issues.

To do this, use "fg" instead of "start" so:

./bin/client1 fg

To me it just seems like your problems are permission and service restart
related.

It might be helpful to jump onto the #plone irc channel and ping people as
your going through the issue.


-Nathan
Post by TsungWei Hu
First, I would try running bin/buildout to rebuild.
Second, I will use a regular Linux account (not root) to run Plone
instace at $HOME directory.
Anyway, good luck!
** ** ** ** ** ** ** **
Had changed ownership so I could check backup files, so changed back to
plone via sudo chown –R plone var****
And got at least splash screen to show, but upon trying to enter my site
got this error:****
** **
CorruptedDataError() (Also, the following error occurred while ****
attempting to render the standard error message, please see the event ***
*
log for full details: Error reading oid 0x0182. Found '' at 60830636)****
** **
stopping and starting netted this result:****
** **
zeoserver: . . . . . . . . . . .****
daemon manager not running****
client1: daemon process already running; pid=28221****
client2: daemon process already running; pid=28230****
** **
------------------------------
*Sent:* Thursday, April 25, 2013 12:24 PM
*To:* **Jody Reed**
*Cc:* plone-users
*Subject:* Re: [Plone-Users] daemon manager not running****
** **
That's odd, system updates should not affect a plone install done with
the unified installer usually.****
** **
Normally when I see the error you're seeing it's because the user running
the plone process no longer has access to the var directory.****
** **
Why don't you try something like:****
** **
sudo chown -R plone /usr/local/Plone/zeocluster/var/****
** **
wrote:****
I'm still trying to figure out the ins and outs of Plone. I am using
4.2.4 and installed using unified installer.****
Today Ubuntu did some updates (running 12.1) Stupid me I did not pay
close attention to what. And now my Plone is troubled.****
I have been banging away at it for a couple hours, and hope I haven't
buggered it completely. Good thing it’s just a test site, bad is I'm
supposed to present on it next week...****
Basically after the Ubuntu updates I lost my connection to blob storage
or that is what it seemed.****
Unfortunately i didn't copy the trace at the time. I went back and tried
restoring the blobstorage and data.fs that I had backed up via repozo
backup script.****
Problem is now the site won't load at all.****
running 'bin/plonectl start' nets:****
****
****
zeoserver: . Error: The directory named as part of the path
/usr/local/Plone/zeocluster/var/zeoserver/zeoserver.pid does not exist.**
**
(line 10 in
file:///usr/local/Plone/zeocluster/parts/zeoserver/etc/zeo.conf)****
For help, use /usr/local/Plone/zeocluster/bin/zeoserver -h****
. . . . . . . . . .****
daemon manager not running****
client1: .****
daemon process started, pid=27564****
client2:****
daemon process started, pid=27566****
****
I have rebooted, rebuilt buildout, stopped and restarted Plone but still
nothing is working…****
****
I'm getting lost here, and before I totally screw things up (if i haven't
already) I would like some feedback.****
****
****
****
***Jody Reed***
Information Systems Assistant ****
[image: LMG Finance Logo] <http://www.lmgfinance.ca>****
****
Toll Free 877.806.6247 | Fax 877.806.6249 | Local 250.374.8804 ****
****347 Victoria Street, Suite 201**, **Kamloops**, **BC**, **V2C 2A3****
****
****Canada****'s F&I Outsource Solution ****
------------------------------
This e-mail may be privileged and/or confidential, and the sender does
not waive any related rights and obligations. Any distribution, use or
copying of this e-mail or the information it contains by other than an
intended recipient is unauthorized. If you received this e-mail in error,
please advise me (by return e-mail or otherwise) immediately. ****
Ce courrier électronique est confidentiel et protégé. L'expéditeur ne
renonce pas aux droits et obligations qui s'y rapportent. Toute diffusion,
utilisation ou copie de ce message ou des renseignements qu'il contient par
une personne autre que le (les) destinataire(s) désigné(s) est interdite.
Si vous recevez ce courrier électronique par erreur, veuillez m'en aviser
immédiatement, par retour de courrier électronique ou par un autre moyen.
****
****
------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt!
http://p.sf.net/sfu/newrelic_d2d_apr
_______________________________________________
Plone-Users mailing list
https://lists.sourceforge.net/lists/listinfo/plone-users****
** **
------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt!
http://p.sf.net/sfu/newrelic_d2d_apr
_______________________________________________
Plone-Users mailing list
https://lists.sourceforge.net/lists/listinfo/plone-users
------------------------------------------------------------------------------
Try New Relic Now & We'll Send You this Cool Shirt
New Relic is the only SaaS-based application performance monitoring service
that delivers powerful full stack analytics. Optimize and monitor your
browser, app, & servers with just a few lines of code. Try New Relic
and get this awesome Nerd Life shirt! http://p.sf.net/sfu/newrelic_d2d_apr
_______________________________________________
Plone-Users mailing list
https://lists.sourceforge.net/lists/listinfo/plone-users
Jody Reed
2013-04-29 14:37:05 UTC
Permalink
Thanks Mikko, Nathan for the IRC link and other help.

I have been out of the office since Thursday; I am going to be diving in
to this today and seeing if I can get it sorted out.

Jody



________________________________

From: Mikko Lehtisalo [mailto:mikkolehtisalo-***@public.gmane.org]
Sent: Saturday, April 27, 2013 12:49 AM
To: Jody Reed
Subject: Re: [Plone-Users] daemon manager not running



Did you manage to find solution?



If not, and you have time pressures, you could always go to the IRC (see
https://plone.org/support/chat ) and ask for help there.
Jody Reed
2013-04-29 20:25:40 UTC
Permalink
This post might be inappropriate. Click to display it.
Continue reading on narkive:
Loading...